Calls continuing to ring after pickup and audio disruption on some accounts.

Incident Report for Nebula Limited

Postmortem

At 11:08am on 19 December, we identified that some calls received by end users continued to ring after pickup. Upon immediate investigation, we identified a series of transient faults in the data store cache triggered a crash in the connected proxies of one of our three zones. Reinitialising the proxies enabled service to resume at approximately 11:30am (service restoration).

Further troubleshooting indicated the data store cache was not able to handle a long log messages (fault cause).

To resolve proxy crashes caused by the data store’s inability to process large log messages, we optimised the configuration by increasing the output buffer and client limits while implementing stricter memory monitoring (service resolution).

Posted Dec 22, 2025 - 16:43 UTC

Resolved

After a successful period of monitoring, we are marking this incident as resolved. We will publish further detail within then next few working days.
Posted Dec 19, 2025 - 19:13 UTC

Monitoring

Expected performance has resumed across the affected zone and we are seeing service return to normal for those affected accounts. We will continue monitoring for an extended period.
Posted Dec 19, 2025 - 11:54 UTC

Update

We are still working on the issue and are seeing improvements in some cases. Will provide a further update in 20 minutes.
Posted Dec 19, 2025 - 11:51 UTC

Identified

Our team have identified the affected services and are working to resolve. Will provide a further update within 20 minutes.
Posted Dec 19, 2025 - 11:30 UTC

Investigating

We're investigating some reports of calls continuing to ring after being picked up by an extension and audio disruption, on some end user accounts. We are seeing traffic flowing normally on most. Our team are investigating with priority. Will provide a further update in 20 minutes.
Posted Dec 19, 2025 - 11:28 UTC
This incident affected: Core Network.