We have identified residual connections to the originally affected server clusters: we flushed these connections at 11:45am and are now seeing service restored for the limited number that are still experiencing issues with dialling.
Posted Nov 17, 2025 - 11:52 GMT
Update
We are still monitoring the issue and are exploring individual cases of poor quality or delayed connection on calls. Will provide a further update in 30 minutes.
Posted Nov 17, 2025 - 11:36 GMT
Update
Note: some customers may experience delay on calls while we clear a backlog of SIP messages, however this is being cleared at speed and we continue to monitor for any ongoing causes.
Posted Nov 17, 2025 - 11:01 GMT
Monitoring
Traffic continues to return to normal for users on the affected zone and we are seeing dashboard load speeds improve. We will continue to provide updates until confident all services have resumed.
Posted Nov 17, 2025 - 10:55 GMT
Identified
We have identified the issue, and have implemented a fix and are seeing systems begin to return to normal, however will continue to monitor and provide further updates once we are confident all services have been restored.
Posted Nov 17, 2025 - 10:48 GMT
Update
We are continuing to investigate the issue. Dashboards are affected for all site visitors, however disruption on voice remains limited to one zone.
Posted Nov 17, 2025 - 10:22 GMT
Update
Dashboards are also affected in some cases. We are working to restore service to calls with priority.
Posted Nov 17, 2025 - 10:04 GMT
Investigating
Our team are investigating reports of call issues with some accounts on one zone. We will provide a further update within 20 minutes.
Posted Nov 17, 2025 - 10:01 GMT
This incident affects: Core Network and Dashboard.