Dashboard and Outbound Call Authentication Issues

Incident Report for Nebula Limited

Resolved

After a period of successful monitoring this incident is marked as resolved.
Posted Jul 11, 2025 - 15:48 BST

Update

We have seen all services return to normal and are actively monitoring the issue. This will be marked as resolved after a period of successful monitoring.
Posted Jul 11, 2025 - 12:41 BST

Update

We are still working on this issue and have seen calls returning to normal in some cases. We are working on reports of issues with chat via our softphone applications.
Posted Jul 11, 2025 - 12:28 BST

Identified

We have identified the issue and working on a fix. Next update within 20 minutes.
Posted Jul 11, 2025 - 12:08 BST

Investigating

Our team are investigating reports of issues with outbound calls and navigating dashboards. We will provide a further update within 30 minutes.
Posted Jul 11, 2025 - 11:56 BST
This incident affected: Core Network, Dashboard, Mobile Applications, and Desktop Applications.