A fix has been implemented and we are monitoring the results.
Posted Oct 17, 2025 - 13:20 BST
Identified
Our team have identified the origin of the issue and are working to restore service ASAP.
Posted Oct 17, 2025 - 12:22 BST
Investigating
Our team are investigating degraded performance across dashboards and softphone applications, including chat and presence. Calls and hardware functions are not affected, and all other services are fully operational.
We're actively working to address and will update within 20 minutes.
Posted Oct 17, 2025 - 12:00 BST
This incident affected: Dashboard, Mobile Applications, and Desktop Applications.