Delay on outbound calls connecting

Incident Report for Nebula Limited

Postmortem

At 12:01 PM GMT today, some users experienced an interruption when placing outbound calls. Inbound routing, internal extension calling, and online dashboards remained fully operational throughout. All services were restored by 12:14 PM GMT.

The issue was caused by an isolated storage component within our Fraud Protection engine. This feature monitors real-time spend, providing an extra layer of security for our customers and partners. The issue was identified, acted upon and resolved within 13 minutes.

Posted Mar 11, 2026 - 14:42 UTC

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 14:41 UTC

Monitoring

The fix has been implemented and we're seeing service restored to all users. We'll continue to monitor closely for a period before marking this as resolved.
Posted Mar 11, 2026 - 12:14 UTC

Identified

We have identified the issue and are implementing a fix. Service should be restored shortly.
Posted Mar 11, 2026 - 12:08 UTC

Update

Inbound calls and dashboards remain unaffected. We are investigating with urgency.
Posted Mar 11, 2026 - 12:06 UTC

Investigating

We're investigating reports of severe post dial delay on outbound calling. Will update in next 20 minutes.
Posted Mar 11, 2026 - 12:01 UTC
This incident affected: Core Network, Mobile Applications, and Desktop Applications.