Post-dial delay and audio issues on softphone apps and handsets

Incident Report for Nebula Limited

Postmortem

Following our initial report regarding the incident on January 12, 2026, our Engineering team implemented several emergency infrastructure upgrades. These improvements successfully mitigated the original risk and provided the enhanced visibility required to monitor this segment of our network more closely.

On the afternoon of January 14, 2026, the same Memory Cache Layer within a single zone experienced a secondary disruption. This resulted in a 40-minute service outage affecting handsets, mobile applications, and in-call media, for accounts in that zone.

Thanks to the telemetry tools installed earlier this week, our team was able to rapidly isolate a specific software bug within this layer. This bug was triggered by recent increases in network traffic. We have since successfully replicated, retested, and deployed a permanent fix across all zones. We will continue to monitor the network closely to ensure continued stability.

Posted Jan 15, 2026 - 17:57 UTC

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 09:11 UTC

Monitoring

A fix has been implemented and we're seeing service has resumed, with all traffic returning to normal. We are continuing to monitor.
Posted Jan 14, 2026 - 16:19 UTC

Update

The issue is isolated to single zone. We are working on restoring service the affected accounts with urgency.
Posted Jan 14, 2026 - 16:07 UTC

Identified

We've identified the issue and are working on a fix.
Posted Jan 14, 2026 - 16:02 UTC

Investigating

We've updated the title to reflect reports of handsets also not working. We are investigating with priority and will provide further information as soon as possible.
Posted Jan 14, 2026 - 15:47 UTC

Identified

We're investigating issues of mobile and desktop apps being unresponsive. We're investigating with priority.
Posted Jan 14, 2026 - 15:40 UTC
This incident affected: Core Network, Mobile Applications, and Desktop Applications.