Disruption to dashboards and calling.
Incident Report for
Nebula Limited
Resolved
This incident is being marked as resolved. Service to wallboards have also been restored.
Posted
Jun
25
,
2026
-
07:54
UTC
Update
Please note wallboards remain offline while we continue our investigation. These will be restored as soon as possible.
Posted
Jun
24
,
2026
-
16:22
UTC
Monitoring
All services are now running as expected and we are monitoring the results.
Posted
Jun
24
,
2026
-
15:48
UTC
Update
A fix has been implemented and we're seeing services returning to normal. Next update 10 minutes.
Posted
Jun
24
,
2026
-
15:44
UTC
Identified
The issue has been identified and a fix is being implemented.
Posted
Jun
24
,
2026
-
15:32
UTC
Investigating
We're investigating reports of dashboards failing to load and inbound and outbound not working. Next update within 15 minutes.
Posted
Jun
24
,
2026
-
15:28
UTC
This incident affected: Core Network and Dashboard.
×
Subscribe to Incident
Subscribe to updates for
Disruption to dashboards and calling.
via . You'll receive .