RESOLVED - Temporary disruption to isolated accounts

Incident Report for Nebula Limited

Resolved

Following essential maintenance works last night, some accounts on a single zone required a clear of routing cache within our database. This caused temporary disruption between 08:15am and 08:35am, however all services have returned to normal operation.
Posted Oct 24, 2025 - 08:42 BST
This incident affected: Core Network.