Disruption to inbound and outbound calls

Incident Report for Nebula Limited

Resolved

After a successful period of monitoring we are marking this incident as resolved.
Posted Nov 18, 2025 - 14:22 GMT

Monitoring

All services have returned to normal and we're hearing positive reports from our customers of the same. We are continuing to monitor all affected parts of the network for a prolonged period before marking as resolved.
Posted Nov 18, 2025 - 11:06 GMT

Update

We've seen reports of services returning to normal. We are continuing to monitor the affected zone closely.
Posted Nov 18, 2025 - 10:55 GMT

Identified

We have identified an issue causing degradation on calls and are working to resolve ASAP. We have rerouted affected traffic and seeing those services returning to normal however this may take a short period to complete. Will provide a further update in 20 minutes.
Posted Nov 18, 2025 - 10:50 GMT
This incident affected: Core Network.