Degraded performance on apps and dashboards
Incident Report for
Nebula Limited
Resolved
This incident has been resolved.
Posted
Nov
03
,
2025
-
10:55
GMT
Monitoring
Service should be restored to normal and we are monitoring affected services closely.
Posted
Nov
03
,
2025
-
09:21
GMT
Identified
Service should be restored to normal and we are monitoring affected services closely.
Posted
Nov
03
,
2025
-
09:21
GMT
Investigating
Our team are investigating disrupted performance on apps and dashboards.
Posted
Nov
03
,
2025
-
09:14
GMT
This incident affected: Dashboard, Mobile Applications, and Desktop Applications.
×
Subscribe to Incident
Subscribe to updates for
Degraded performance on apps and dashboards
via . You'll receive .